Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Support.box.com is only available for users who login
Incident Report for Box
Resolved
Access to https://support.box.com has been fully restored.
Posted almost 2 years ago. Feb 27, 2015 - 15:13 PST
Investigating
We identified that users must login to Box on support.box.com before they are able to access our support site. We are currently investigating the cause of the issue.
Posted almost 2 years ago. Feb 27, 2015 - 14:00 PST