After further monitoring, this incident is now considered resolved. Our Services have been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Sep 29, 2024 - 23:58 PDT
Identified
Our team has identified the underlying cause of this issue and is working to take remediating steps. We will provide additional updates as they become available.
Posted Sep 29, 2024 - 23:53 PDT
Update
Our team is investigating a slowness issue that could affect the Box Web application. Users may see slowness when attempting to upload items to Box. We will provide additional information as it becomes available.
Posted Sep 29, 2024 - 23:49 PDT
Investigating
Our team is investigating a slowness issue that could affect the Box Web application, Box Drive and API calls. Users may see slowness when attempting to upload items to Box. We will provide additional information as it becomes available.
Posted Sep 29, 2024 - 23:41 PDT
This incident affected: Box Platform / API (Content API), Box Web Application (Uploads/Downloads), and Desktop Applications (Box Drive).