For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[MAJOR] Issues with Logins, All Files page
Incident Report for Box
Postmortem

Notice and disclaimer: Box is providing this preliminary information subject to further review and analysis. To the best of our knowledge, this is the current state and we may update as more information is confirmed.

On May 29, 2024, between 1:39 am and 6:40 am PDT, some users may have experienced difficulties while working in Box. Over the course of this period, there were several 60-90 second time intervals when logins and various other functionality was impaired. This issue occurred due to a recent change in our token rotation process as part of our ongoing efforts to enhance the security of our systems. We resolved the problem by overriding the process and updating the expired tokens. Additionally, we are actively working on improving our testing procedures to prevent similar issues from happening again in the future.

We are conducting a full engineering postmortem and our overview is subject to change with further analysis and findings. In the event our continuing investigation yields further substantive findings, we may publish additional analysis after the conclusion of the full engineering postmortem.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Jun 10, 2024 - 17:01 PDT

Resolved
After further monitoring, this incident is now considered resolved. Our Service has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted May 29, 2024 - 06:54 PDT
Update
Our team is still monitoring the issue and is seeing improvement for authentication and accessing to the All Files page. We are continuing to monitor for any additional impact.
Posted May 29, 2024 - 05:36 PDT
Update
Our team is still monitoring the issue and is seeing improvement for authentication and accessing to the All Files page. We are continuing to monitor for any additional impact.
Posted May 29, 2024 - 04:34 PDT
Monitoring
Our team has taken steps to remediate this issue and is seeing improvement for authentication and accessing to the All Files page. We are continuing to monitor for any additional impact.
Posted May 29, 2024 - 03:35 PDT
Investigating
Our team is investigating an issue with the login page, authentication, and All files page. Users may see errors or slowness when attempting to access to Box. We will provide additional information as it becomes available.
Posted May 29, 2024 - 03:32 PDT
This incident affected: Box Web Application (Login/SSO).