For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issues with Logins, Folder and File Preview, and Shared Links

Incident Report for Box

Resolved

After further monitoring, this incident is now considered resolved. Our teams have validated that all affected services are restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Mar 19, 2026 - 22:08 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2026 - 21:44 PDT

Update

We are continuing to investigate this issue.
Posted Mar 19, 2026 - 21:14 PDT

Investigating

We are continuing to investigate this issue.
Posted Mar 19, 2026 - 21:13 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 19, 2026 - 20:59 PDT

Investigating

We are investigating an ongoing issue affecting folder and file preview. Customers may experience a white or blank page when loading subfolders and accessing shared links. We will provide more information as soon as it is available.
Posted Mar 19, 2026 - 20:37 PDT
This incident affected: Box Web Application (Login/SSO, Preview, Sharing (Shared Links)).