For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Issues with Uploads

Incident Report for Box

Resolved

This incident is now considered resolved. Box uploads have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Jun 24, 2026 - 05:33 PDT

Investigating

We are investigating an ongoing issue affecting uploads. We will provide more information as soon as it is available.
Posted Jun 24, 2026 - 05:18 PDT
This incident affected: Box Web Application (Uploads/Downloads).