For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Delay in generating Admin Reports
Incident Report for Box
Resolved
We have completed our monitoring period and are considering the issue fully resolved. If you are seeing any new issues, please let us know at https://support.box.com.
Posted Apr 16, 2021 - 18:54 PDT
Update
As of 5 PM PST, we are no longer seeing customer delays to Admin Reports. We will continue to monitor and provide an update in one hour.
Posted Apr 16, 2021 - 17:57 PDT
Monitoring
We are no longer seeing customer delays to Admin Reports. We will continue to monitor and provide an update in one hour.
Posted Apr 16, 2021 - 17:49 PDT
Update
We are continuing to investigate this issue. We will provide more information as soon as it is available.
Posted Apr 16, 2021 - 12:24 PDT
Identified
We are continuing to investigate this issue.
Posted Apr 16, 2021 - 10:15 PDT
Investigating
We are investigating an issue impacting Admin Reports run by Admin/Co-Admins in the Admin Console and the Admin Events API endpoint. We will provide more information as soon as it is available.
Posted Apr 15, 2021 - 20:30 PDT
This incident affected: Box Platform / API (Content API) and Box Web Application (Admin Console & Functionality).