For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

Issue with accessing Box.org, Community Site, and Submitting of tickets
Incident Report for Box
Resolved
From approximately 11:28 PM to 12:10 AM US Pacific time, our Box.org Community Site, the Community and Support Site at https://support.box.com was experiencing issues resulting in the degradation of our support channel workflows and ability to post updates in our Community Forums. We are monitoring resolution with a third-party vendor and have confirmed the issue is no longer happening. We apologize for any inconvenience.
Posted Jun 20, 2022 - 23:30 PDT