For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Errors returned from search
Incident Report for Box
Postmortem

We recently addressed issues affecting the Search Platform. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 5:00 pm PDT on May 18, 2022 and 1:00 am PDT on May 19, 2022, some users may have experienced difficulties while working in Box. During this time, a minority of users were shown an error message when attempting a search. The issue occurred as a result of a recent code change made relating to the improvement of search ranking results. We were able to resolve the issue by rolling back this change immediately upon discovery. In addition, we are implementing new alerts and enhancing our detection capabilities to prevent similar issues from occurring in the future.

Analysis

On May 18th, a configuration change was made in an effort to improve the ranking of Search results. The configuration was incorrectly applied for a small percentage of users of Search. As a result, during this time, this small group of impacted users received an error message instead of the expected results.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Engineers immediately reversed the incorrect configuration.
  • The team has enhanced alerting and detection surrounding future configuration changes.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.‌

Sincerely,

The Box Team

Posted May 31, 2022 - 13:56 PDT

Resolved
We have completed the extended monitoring period and are considering the issue resolved. If you experience any new issues with search, please reach out to the Box Support team at https://support.box.com.
Posted May 19, 2022 - 01:10 PDT
Monitoring
Box Engineering has resolved the issue concerning the Box Search service and are now monitoring to ensure no further impact is observed.
Posted May 19, 2022 - 00:15 PDT
Identified
Box Engineering has identified the issue concerning the Box Search service and is working to remediate the issue. Some users may see their search is returning the expected results now.
Posted May 18, 2022 - 23:58 PDT
Investigating
Box Engineering is currently investigating an issue with the Box Search service. Users may see issues searching their Box content. Webapp users may see a "Sorry, there was an error performing the search. There is a problem with search right now.” message.
Posted May 18, 2022 - 23:52 PDT
This incident affected: Box Web Application (Search).