For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Degradation of Search
Incident Report for Box
Postmortem

We recently addressed issues affecting Search. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between March 7, 2023 5:00 PM PT and March 10, 2023 11:00 AM PT, some users may have experienced difficulties while working in Box. During this time, some recently uploaded and updated documents were delayed in processing and did not appear in Search results. The issue occurred during a code change to improve Search’s processing capability. We were able to resolve the issue by removing the change and increasing the computing power of our pipeline. In addition, we have increased alerting and implemented stricter testing and more automation to prevent similar issues from occurring in the future.

Analysis

At Box, we are always striving to improve the efficiency and fault tolerance of our services. The Search team implemented a change to improve the processing pipeline of documents that were uploaded to Box.

A bug went undiscovered during our automated and manual testing phases, leading to a lag in processing time. Once discovered and remediated, we immediately went about clearing the backlog of lagged items in our processing queue. This issue revealed gaps in our internal team process for such rollouts, in addition to gaps in our testing mechanisms.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Add in more alerting and automated processes to prevent future complications
  • Long-term migration to more stable sub-systems
  • Extra automation around testing rollouts for changes to the processing pipeline

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Mar 15, 2023 - 14:35 PDT

Resolved
After further monitoring, this incident is now considered resolved. Search has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Mar 10, 2023 - 11:15 PST
Update
Our team is working on the backlog to alleviate the degradation of search. We will continue to monitor and provide additional updates as they become available.
Posted Mar 10, 2023 - 07:15 PST
Update
Our teams are still working to address the issue on the degradation of search. We will provide additional updates as they become available.
Posted Mar 09, 2023 - 22:49 PST
Update
Our teams are still working to address the issue on the degradation of search. We will provide additional updates as they become available.
Posted Mar 09, 2023 - 18:28 PST
Update
Our teams are still working to address the issue on the degradation of search. We will provide additional updates as they become available.
Posted Mar 09, 2023 - 14:15 PST
Update
We are seeing signs of the search issue being partially resolved. Our teams are still reviewing options to fully resolve the search issue. We will continue to monitor and provide additional updates as they become available.
Posted Mar 09, 2023 - 07:30 PST
Identified
Our team has identified the underlying cause of this issue and is working to take remediating steps. We will provide additional updates as they become available.
Posted Mar 09, 2023 - 00:54 PST
Update
We are continuing to investigate this issue.
Posted Mar 08, 2023 - 22:23 PST
Update
We are continuing to investigate this issue.
Posted Mar 08, 2023 - 20:00 PST
Update
We are continuing to investigate this issue.
Posted Mar 08, 2023 - 17:51 PST
Update
We are continuing to investigate this issue.
Posted Mar 08, 2023 - 15:26 PST
Update
We are continuing to investigate this issue.
Posted Mar 08, 2023 - 13:00 PST
Update
We are continuing to investigate this issue and working on a potential remediation to speed up recovery.
Posted Mar 08, 2023 - 10:00 PST
Investigating
We are currently investigating an issue with search. Search is still currently operational but does not provide the most up-to-date results. We believe the degradation to search started after 03/07/2023 5:15 PM PST.

We are actively investigating and will provide more information as soon as it is available. In the meantime, please expect there to be delays in searching for new content.
Posted Mar 08, 2023 - 08:30 PST
This incident affected: Mobile Applications (Search), Box Web Application (Search), and Box Platform / API (Search).