Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be experiencing degradation of service
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. Please report any outstanding issues to Box User Services via https://community.box.com/help
Posted 11 months ago. Aug 22, 2016 - 18:45 PDT
Monitoring
Box services are now fully operational. This includes FTP, WebDav, Box Notes, Uploads, Content API, Preview, and Mobile. We will continue monitoring this to ensure that no issues arise.
Posted 11 months ago. Aug 22, 2016 - 18:21 PDT
Identified
Some users may be experiencing issues because of degradation of Box services, including Box Notes, Box API, preview, and uploads. Engineers are working on stabilization path.
Posted 11 months ago. Aug 22, 2016 - 17:10 PDT