For more informtion about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Some Webhooks May Not Respond
Incident Report for Box
Postmortem

NOTICE AND DISCLAIMER: CUSTOMER UNDERSTANDS AND AGREES THAT THIS IS PRELIMINARY INFORMATION SUBJECT TO FURTHER REVIEW AND ANALYSIS BY BOX. TO THE BEST OF OUR KNOWLEDGE, THIS IS THE CURRENT STATE AND WILL BE UPDATED AS MORE INFORMATION IS CONFIRMED.

LAST UPDATED: July 29, 2020

We recently addressed issues affecting Webhooks V2. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future. 

Between 1:10pm PDT and 7:20pm PDT on 7/20/2020, some users may have experienced difficulties while working in Box. During this time, Webhooks configured to use signatures did not receive events as expected. The issue occurred as a result of a configuration change related to updates we were making to Webhooks. We were able to resolve the issue by reverting our change and restoring the service. In addition, we have identified the source of the issue and are taking a number of steps (including but not limited to adding fallback logic to handle this issue, additional test cases, additional review steps, more specific monitoring/alerting, etc.) to prevent similar issues from occurring in the future. 

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Jul 29, 2020 - 08:11 PDT

Resolved
We have completed our monitoring period and are considering the issue fully resolved. If you are still experiencing any issues, please contact us via https://support.box.com.
Posted Jul 20, 2020 - 20:18 PDT
Monitoring
We have implemented a change and the impact to Webhooks should now be remediated. We will continue internal monitoring to ensure no additional impact is observed.
Posted Jul 20, 2020 - 19:45 PDT
Investigating
Our team is currently investigating an issue where some Webhooks may not respond as expected. We will provide additional information as it becomes available.
Posted Jul 20, 2020 - 19:07 PDT
This incident affected: Box Platform / API (Webhooks).