Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Users are unable to rename files on the "All Files" page
Incident Report for Box
Resolved
This issue has been resolved. We have not observed any further issues. If you experience any problems, please reach out to us at https://support.box.com
Posted 12 months ago. Mar 02, 2016 - 20:18 PST
Investigating
Files cannot be renamed in the root directory. A temporary workaround is to move the respective file into a subfolder, rename it, then move it back to the "All Files" page. We are currently investigating this issue.
Posted 12 months ago. Feb 29, 2016 - 15:59 PST
This incident affected: Box Website and Content API.