For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Issue with Logins & Files Page

Incident Report for Box

Postmortem

Between 3:44 PM and 4:27 PM PDT on August 19, 2026 and 10:28 AM and 11:21 AM PDT on August 24, 2026, some users may have experienced intermittent errors with some Box features, including Logins, Uploads, Downloads, and Box Sign.

The issues occurred after a rapid surge of external Box client connections overwhelmed front-end capacity in the affected region, which caused an increase in server-side error rates and prevented some requests from reaching our back-end services. We restored service by working with our cloud provider and applying operational mitigations until front-end error rates returned to normal and user requests succeeded again.

Analysis

This incident highlighted opportunities to improve our detection and correlation of frontend/load balancer health signals with our application telemetry and to strengthen joint monitoring and mitigation processes with our cloud provider during large-scale client connection events. It also underscored the importance of clearer detection thresholds and runbook steps for frontend degradations, so we can escalate and remediate faster without over or under communicating impact to customers.

Corrective Actions

Box has initiated the following corrective actions:

  • Improving monitoring and observability for large-scale client connection events and working with our cloud provider on coordinated mitigation strategies.
  • Coordinating with our cloud provider to ensure connection rates are within expected thresholds.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.

Sincerely,

The Box Team

Posted Aug 30, 2026 - 15:39 PDT

Resolved

From approximately 10:28 AM to 10:35 AM US Pacific time, we observed an issue intermittently impacting some Logins and the Files page view. Our systems automatically detected and corrected the underlying issue. There is no current impact and no further updates will be provided here. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Aug 24, 2026 - 10:30 PDT