On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Issues with Uploads and Downloads
Incident Report for Box
Resolved
The issue has been fully resolved and users should see no new errors with uploads and downloads. If you do experience any new issues when uploading or downloading, please let us know at https://support.box.com.
Posted 8 days ago. Nov 07, 2018 - 15:22 PST
Identified
The issue has been identified and we are currently implementing remediation items. Users may still see errors, but upload and download functionality is returning to normal levels. We will provide updates as soon as possible.
Posted 8 days ago. Nov 07, 2018 - 15:17 PST
Investigating
We are currently investigating an issue with Uploads and Downloads to Box. We will provide updates as soon as possible.
Posted 8 days ago. Nov 07, 2018 - 15:11 PST
This incident affected: Box Web Application (Uploads/Downloads), Mobile Applications (Uploads/Downloads), Box Platform / API (Uploads/Downloads), and FTP, WebDAV.