On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Issue with Uploads, Downloads, Box Edit, API
Incident Report for Box
Resolved
We have resolved the issue, the monitoring period following resolution has ended, and no further impact has been observed. If you continue to experience any issues, please contact Box User Services at https://support.box.com
Posted 8 months ago. Jan 22, 2019 - 15:23 PST
Monitoring
We are continuing to monitor the affected services to ensure no further impact is observed. Box Edit users should no longer see errors when opening files on Box.
Posted 8 months ago. Jan 22, 2019 - 13:53 PST
Update
We’ve remediated the impact of the issue with Uploads, Downloads, and API. Before remediation, Box customers may have seen 503 errors with Box API/Platform. Box Edit users may continue to see errors when opening files on Box.
Posted 8 months ago. Jan 22, 2019 - 12:30 PST
Identified
We have identified the issue and are still actively remediating the impact. Some Box Edit users may see errors when opening files. If you see an error please retry or manually download the file to make changes. Device Trust is not impacted by this Box Edit issue.
Posted 8 months ago. Jan 22, 2019 - 11:46 PST
Update
We are continuing to investigate issues with uploads and downloads. We will provide updates here as soon as possible.
Posted 8 months ago. Jan 22, 2019 - 10:02 PST
Investigating
We are investigating an issue with Uploads and Downloads starting at approximately 7:52 AM Pacific time. A small percentage of users may see errors while uploading or downloading. We will provide updates here as soon as possible.
Posted 8 months ago. Jan 22, 2019 - 09:00 PST
This incident affected: Box Web Application (Uploads/Downloads), Desktop Applications (Box Edit / Tools), Mobile Applications (Uploads/Downloads), Box Platform / API (Uploads/Downloads), and FTP, WebDAV.