For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Issues with Box Relay
Incident Report for Box
Postmortem

NOTICE AND DISCLAIMER: CUSTOMER UNDERSTANDS AND AGREES THAT THIS IS PRELIMINARY INFORMATION SUBJECT TO FURTHER REVIEW AND ANALYSIS BY BOX. TO THE BEST OF OUR KNOWLEDGE, THIS IS THE CURRENT STATE AND WILL BE UPDATED AS MORE INFORMATION IS CONFIRMED.

LAST UPDATED: July 29, 2020

We recently addressed issues affecting Box Relay, Metadata, and Notifications. We would like to take the opportunity to further explain these issues and the steps we have taken to keep similar issues from happening in the future.

Between 11:15 AM and 12:29 PM PDT on Wednesday, July 15, some users may have experienced difficulties while working in Box. During this time, Box Relay workflows, notifications, and metadata cascading to files was delayed. The issue occurred as a result of a recent configuration change where several servers did not accept the new configuration and instead stopped processing events. We were able to resolve the issue by manually bouncing the affected servers. These servers were already being upgraded to improve stability and reliability and we have accelerated this work to prevent similar issues from occurring in the future.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Jul 29, 2020 - 11:43 PDT

Resolved
We have completed monitoring and are considering the issue resolved. If you are seeing any issues when using Box, please contact us at https://support.box.com.
Posted Jul 15, 2020 - 12:14 PDT
Investigating
We are currently investigating an incident related to Box Relay. Additional information will be provided as it becomes available.
Posted Jul 15, 2020 - 12:12 PDT
This incident affected: Box Relay.