On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Issue with Uploads and Downloads
Incident Report for Box
Resolved
We have resolved the issue with Uploads and Downloads. No further impact has been observed. If you continue to experience any issues, please contact Box User Services at https://support.box.com/
Posted 3 months ago. Feb 19, 2019 - 10:48 PST
Investigating
We are currently investigating an issue that may cause latency with uploads and downloads. Users may also see delays with edits made in Office Online saving back to Box. We will provide an update as soon as possible.
Posted 3 months ago. Feb 19, 2019 - 09:33 PST
This incident affected: Partners / Integrations (Microsoft Online), Box Platform / API (Content API, Uploads/Downloads), Box Web Application (Uploads/Downloads), Mobile Applications (Uploads/Downloads), and FTP, WebDAV.