Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Degraded Download Experience
Incident Report for Box
Resolved
The issue with download performance has been resolved. Please report any new issues to https://support.box.com.
Posted almost 2 years ago. May 18, 2015 - 16:41 PDT
Monitoring
Our Operations Team has confirmed download performance has improved back to normal levels. They will continue monitoring for the next few hours to ensure full stability.
Posted almost 2 years ago. May 18, 2015 - 14:55 PDT
Identified
Box Operations Teams have identified download degradation may be related to a network peering through which some Internet traffic to Box is routed. They are urgently working to resolve this with the identified provider.
Posted almost 2 years ago. May 18, 2015 - 13:15 PDT
Investigating
Some customers may be experiencing a degraded download experience. Box Operations Teams are actively investigating.
Posted almost 2 years ago. May 18, 2015 - 11:34 PDT
This incident affected: Box Website and Downloads.