Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Email Delivery May Be Delayed for Some Users
Incident Report for Box
Resolved
The monitoring period has ended and no further impact has been observed. If you continue to experience any issues, please contact the Box User Services team via https://community.box.com
Posted 9 months ago. Jan 03, 2017 - 07:10 PST
Monitoring
Box Engineers have remediated the issue, and emails should be working again as expected. We will monitor to ensure no further issues.
Posted 9 months ago. Jan 03, 2017 - 05:49 PST
Identified
Some users may be experiencing delays in email delivery, our engineers have identified the issue and are working to resolve it.
Posted 9 months ago. Jan 02, 2017 - 16:10 PST
This incident affected: Email Notifications.