Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Users are Unable to Submit Support Cases on the Box Community
Incident Report for Box
Resolved
The monitoring period has ended for this issue and no further impact has been observed.
Posted 9 months ago. Oct 18, 2016 - 12:32 PDT
Monitoring
Our third-party integration has identified and remediated issues in their environment. The ability to submit new and view existing cases through the Box Community should be restored. We are monitoring closely to ensure full resolution.
Posted 9 months ago. Oct 18, 2016 - 10:08 PDT
Identified
When attempting to submit a support case through the Box Community, users may see an error and will unable to proceed further. Viewing of existing support cases is also impacted. The root cause has been traced to a connectivity issue with a third-party integration. We are in close contact with this vendor to monitor their progress toward resolution.
Posted 9 months ago. Oct 18, 2016 - 09:32 PDT