For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

Some Internet Explorer users may be experiencing issues with Content Preview
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. If you continue to see issues using Box.com with Internet Explorer, please contact our Box User Services team at https://community.box.com/help.
Posted Jun 22, 2017 - 18:00 PDT
Monitoring
Box Engineering has identified and remediated the issue. Content Previews and other webapp functionality should be working now for Internet Explorer users. We will monitor to ensure no further impact.
Posted Jun 22, 2017 - 17:38 PDT
Investigating
Some Box users using Internet Explorer may be experiencing issues with Content Preview and other webapp actions. Box Engineering is currently investigating the cause of the problem.
Posted Jun 22, 2017 - 17:05 PDT
This incident affected: Box Platform / API (Content Preview).