For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

Some Users May Experience Issues Logging Into Box
Incident Report for Box
Resolved
The monitoring period has ended and no further impact has been observed. If you continue to experience any issues, please contact the Box User Services team via https://community.box.com/help.
Posted Jun 15, 2017 - 15:51 PDT
Monitoring
Box Engineers have pushed a fix, and are monitoring to ensure there is no further impact.
Posted Jun 15, 2017 - 15:05 PDT
Identified
Box Engineers have identified the source of the issue and are working to remediate.
Posted Jun 15, 2017 - 14:41 PDT
Investigating
Box Engineering is investigating an issue that may prevent some users from being able to login to their account.
Posted Jun 15, 2017 - 14:11 PDT