Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Collaboration Sidebar Not Showing Collaborators
Incident Report for Box
Resolved
Collaborations sidebar issue is now resolved and should be displaying correctly.
Posted over 2 years ago. Feb 10, 2015 - 15:44 PST
Identified
The Collaboration sidebar in the Box Webapp is not displaying the list of collaborators for some users. Box Engineering Teams are actively working to resolve this issue.
Posted over 2 years ago. Feb 10, 2015 - 06:59 PST
This incident affected: Box Website.