For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Issues with Email Notification Delivery
Incident Report for Box
Resolved
We're considering the issue fully resolved at this time. If you receive any new issues, please let us know at https://support.box.com.
Posted Nov 05, 2018 - 21:24 PST
Monitoring
Notifications continue to be delivered as expected and previously queued emails have been processed. We’re monitoring the email notification delivery service to ensure full stability. We’ll provide more updates and information as soon as possible.
Posted Nov 05, 2018 - 21:11 PST
Identified
We have reverted a change and email notification delivery rates for the affected notification types (upload, download, preview, delete, and comment notifications) have returned to normal. Previously queued emails are also being processed. We appreciate your patience and will provide more updates and information as soon as possible.
Posted Nov 05, 2018 - 20:35 PST
Update
We are continuing to investigate the degradation of the email delivery service. We'll provide more updates as soon as possible.
Posted Nov 05, 2018 - 20:11 PST
Update
We are continuing to investigate the issue and implement remediation actions. As part of the remediation, customers may have received the same email twice for notifications delivered during a short timeframe at approximately 7:05 PM Pacific. We appreciate your patience and will continue to provide new information and updates as soon as possible.
Posted Nov 05, 2018 - 19:11 PST
Update
Notifications are beginning to deliver as we investigate and implement remediation items. Customers may see notifications deliver at a reduced rate. As deliveries remain below normal volume, we are continuing to investigate the issue to return the service to full functionality.
Posted Nov 05, 2018 - 18:19 PST
Update
We are continuing to investigate the issues with email notification delivery. The issue began at approximately 3:50 PM Pacific time, and is limited to folder or user level notifications for uploads, downloads, previews, deletes, and comments. We will provide additional information and updates as soon as possible.
Posted Nov 05, 2018 - 17:51 PST
Investigating
We are currently investigating an issue with sending notification emails for uploads, downloads, previews, deletes, and comments. Other e-mail types, including but not limited to direct at-mentions, password resets, and collaboration invites are not affected. The affected email types are not currently being sent, but are still being queued for delivery. We will provide more updates as soon as possible.
Posted Nov 05, 2018 - 16:52 PST
This incident affected: Box Web Application (Email Notifications).