On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

Issue Accessing www.box.com, Box Downloads, Box Notes, and Box Relay
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. If you are experiencing any issues using Box, please let us know at https://support.box.com.
Posted 2 months ago. Apr 08, 2019 - 09:13 PDT
Monitoring
All impact from the issue has been remediated as of around 8:11 AM Pacific. We will continue monitoring to ensure no further impact is observed.
Posted 2 months ago. Apr 08, 2019 - 09:00 PDT
Identified
We have identified the issue, have taken steps to restore services, and are seeing recovery from the impact. In addition to issues accessing the www.box.com site, some users may have also seen increased errors downloading files from Box, using Box Notes, and using Box Relay services.
Posted 2 months ago. Apr 08, 2019 - 08:50 PDT
Update
Box.com's home page is now accessible. We are continuing to investigate the source of the issue and will provide updates as soon as possible.
Posted 2 months ago. Apr 08, 2019 - 08:24 PDT
Investigating
We are currently investigating an issue with accessing www.box.com's homepage, including www.box.com/pricing and www.box.com/careers. This issue does not impact core Box services, including uploads and downloads. Users attempting to log in through the web application should use account.box.com/login. We will provide more information as it becomes available.
Posted 2 months ago. Apr 08, 2019 - 08:18 PDT
This incident affected: Box Notes (Web Application, Desktop Client), Box Relay (Relay Tasks, Workflows, and Templates, Relay Workflow API), Box Web Application (Uploads/Downloads), and Box Website.