On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Degradation of the Microsoft Online Integration
Incident Report for Box
Resolved
Microsoft has resolved the Office Online issues (https://status.office.com/) and we are considering the issue resolved.

If you are still experiencing issues previewing or opening files on Box using Office Online or the Excel Online Previewer, please reach out to us at https://support.box.com.
Posted 2 months ago. Sep 04, 2018 - 21:52 PDT
Monitoring
Microsoft is still mitigating the issue and has not declared that the issue is fully resolved yet: https://status.office.com/
https://azure.microsoft.com/en-us/status/

Our testing and customer reports indicate most users are now able to successfully preview and open files on Box using the Excel Online Previewer and Office Online integrations.

We are continuing to monitor the status of the issue and the next update will be provided here when Microsoft has fully resolved the issue.
Posted 2 months ago. Sep 04, 2018 - 15:35 PDT
Update
Microsoft is continuing to work on mitigating the issue impacting Office Online and the Excel Online Previewer. We are continuing to monitor until the issue is resolved. We also recommend following https://status.office.com/ and https://azure.microsoft.com/en-us/status/ for the latest updates from Microsoft.
Posted 2 months ago. Sep 04, 2018 - 12:11 PDT
Update
We are starting to see the recovery of Microsoft's services that impacted the ability to preview Excel spreadsheets and edit documents in Microsoft Online. We will continue to monitor to ensure full remediation.
Posted 2 months ago. Sep 04, 2018 - 09:27 PDT
Update
Microsoft continues their efforts to remediate this issue. They are also updating affected components at the aforementioned status sites https://status.office.com and https://azure.microsoft.com/en-us/status.

For Box customers experiencing an error while attempting to preview a Microsoft Excel document, please refer to the following documentation to temporarily disable the Excel Online Previewer: https://community.box.com/t5/How-to-Guides-for-Managing/Excel-Online-Previewer/ta-p/30633
Posted 2 months ago. Sep 04, 2018 - 08:32 PDT
Identified
We have identified an issue impacting our integration with Microsoft Online. Some users may receive an error while attempting to preview an Excel spreadsheet from the Box Web Application or edit documents in Office 365.

Microsoft has acknowledged a related incident impacting a subset of their customers and is providing updates at https://status.office.com and https://azure.microsoft.com/en-us/status.

We are actively monitoring this event and will provide an update when the service is fully restored.
Posted 2 months ago. Sep 04, 2018 - 06:52 PDT
This incident affected: Box Platform / API (Content Preview).