Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Intermittent preview errors.
Incident Report for Box
Resolved
As of 12:12 PDT, the issue with preview is now resolved.
Posted about 3 years ago. Sep 16, 2014 - 12:43 PDT
Monitoring
Some users may have experienced intermittent errors with the preview service.
Posted about 3 years ago. Sep 16, 2014 - 12:23 PDT
This incident affected: Content Preview.