For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Box University outage
Incident Report for Box
Resolved
We are able to confirm the issues with the Box University site have been resolved. Users should now be able to login to Box University and access their education/training material. If you are still seeing any issues, please let us know at https://support.box.com
Posted Oct 18, 2018 - 16:45 PDT
Identified
The third party vendor we use for Box University has reported an outage. We are working closely with the vendor to resolve the issue as soon as possible.
Posted Oct 18, 2018 - 13:32 PDT