For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issues with Uploads, Downloads and Logins
Incident Report for Box
Postmortem

We recently addressed issues affecting the Box service. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 3:58PM PDT and 5:42PM PDT on August 2, 2022, a small subset of our users may have experienced difficulties while working in Box. During this time, some users of Box would have seen high latency or errors using the Box service. The issue occurred as a result of a result of a backend database receiving an increased volume of traffic that caused it to lag in responding to requests. We were able to resolve the issue by temporarily throttling the traffic. In addition, we changed a configuration value to more effectively utilize our caches and prevent similar issues from occurring in the future. 

Analysis

One of our internal database clusters experienced increased latency as a result of heavier-than-expected traffic from a subset of users. This may have resulted in latent or failed requests to Box for users who were assigned to this particular database cluster. In order to reduce load and improve latency on this cluster, our database engineers temporarily implemented a targeted throttler to reduce the volume of heavier traffic requests which restored overall service to nominal levels. In addition, our engineers identified and changed a configuration value that increased the effectiveness of our cache utilization when responding to this type of heavy traffic. By utilizing the cache more effectively, we are able to avoid sending such heavy traffic to the database, thus preventing similar issues from occurring in the future.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Change the cache configuration value to reduce load on the database when experiencing similar heavy traffic
  • Implement more detailed monitoring in order to more quickly identify the source of heavy traffic to the database

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Sep 06, 2022 - 07:43 PDT

Resolved
After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Aug 02, 2022 - 18:13 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 02, 2022 - 17:50 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 02, 2022 - 17:43 PDT
Investigating
We are investigating an ongoing issue affecting uploads, downloads, logins. We will provide more information as soon as it is available.
Posted Aug 02, 2022 - 17:00 PDT
This incident affected: Box Platform / API (Content API), Box Web Application (Login/SSO, Uploads/Downloads), and Box Notes (Web Application).