On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

Momentary Degradation of Box Services
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. If you continue to experience any issues, please contact Box User Services at https://community.box.com/t5/Contact-Support/ct-p/BoxSupport
Posted 8 months ago. Mar 16, 2018 - 16:18 PDT
Monitoring
Box has remediated the issue and is monitoring to ensure no further impact on Box Web Application or Box endpoints.
Posted 8 months ago. Mar 16, 2018 - 16:02 PDT
Identified
Box is investigating reports of a momentary issue with the Box Web Application and other endpoints. Affected services are subject to change as the investigation continues. Affected users may have observed 500/Page Not Loading errors in the Box Web Application and API endpoints. While access to Box is recovering, Box Notes still appears to be impacted by this event.
Posted 8 months ago. Mar 16, 2018 - 15:49 PDT
This incident affected: Box Platform / API (Content API), Desktop Applications (Box Sync), and FTP, WebDAV.