For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[MInor] Customers may have been experiencing failures when using Box Sign
Incident Report for Box
Postmortem

We recently addressed issues affecting Box Sign. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between March 13, 2023 and March 15, 2023, some users may have experienced difficulties while working in Box. During this time, some users may have encountered loading issues while trying to sign a document. The issue occurred as a result of the release of a new feature in Box Sign. In connection with this release, there was a change in a specific flow for some enterprises based on their enterprise settings. We were able to resolve the issue in the short term by disabling the new feature in affected enterprises. We were subsequently able to release a fix that handled that flow properly. In addition, we are working on updating our monitoring and testing to minimize the likelihood of similar issues occurring in the future. 

*Analysis *

Before signing a document using Box Sign, users must acknowledge an Electronic Record and Signature Disclosure (ERSD). The ERSD is presented on a modal that requires a user to mark a checkbox and submit their acknowledgment of the ERSD. Standard language is provided by default, but enterprises can change the text in their admin console or disable the ERSD.

The ERSD text is received from our backend by the frontend and it shows a loading spinner until it receives this text. In connection with the release of a new feature in Box Sign, the event listener was not configured to properly handle situations in which the ERSD was disabled. This caused users for whom the ERSD was disabled to experience an endless loading loop and as a result, these users were temporarily unable to sign a document. We were able to resolve this issue by deploying the solution with proper handling of the event.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Add additional end to end tests for this particular use case.
  • Implement additional monitoring to closely track the duration for which the loading spinner is displayed.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Apr 04, 2023 - 06:31 PDT

Resolved
Between March 14th, 2023, 7:16AM PT to March 15th, 2023, 10:42AM PT, a small subsection of our users may have experienced issues with our Box Sign service. No further impact has been observed and we are considering this issue to be resolved. If you are still experiencing any issues, please let us know at https://support.box.com
Posted Mar 13, 2023 - 19:00 PDT