After further monitoring, this incident is now considered resolved. Microsoft Office Online and Box Edit has been restored to full functionality.
Posted Jul 16, 2026 - 14:48 PDT
Monitoring
Our team has taken steps to remediate this issue and is seeing improvement for the Microsoft Online service and Box Edit.
Posted Jul 16, 2026 - 14:47 PDT
Identified
Our team has identified the underlying cause of this issue and is working to take remediating steps.
Posted Jul 16, 2026 - 14:45 PDT
Update
We are continuing to investigate this issue.
Posted Jul 16, 2026 - 14:30 PDT
Investigating
Box is investigating reports of a momentary issue with Box Edit / Microsoft Office Online. Affected services are subject to change as the investigation continues.
Posted Jul 16, 2026 - 14:30 PDT
This incident affected: Partners / Integrations (Microsoft Office Integration) and Desktop Applications (Box Edit / Tools).