On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

Degradation of the Search Service
Incident Report for Box
Resolved
The extended monitoring period for this issue has ended and no additional impact has been observed. If you are still experiencing issues with Box Search, please reach out to our User Services team at https://support.box.com.
Posted 8 months ago. Mar 29, 2018 - 12:03 PDT
Update
Box Engineering is continuing the extended monitoring period to ensure no further impact is observed for Box Search users. The next update will be provided tomorrow, March 29, at approximately 9:00 AM Pacific or at the next change of status.
Posted 8 months ago. Mar 28, 2018 - 13:21 PDT
Monitoring
Box Engineering has resolved the issue with the Box Search service and is entering an extended monitoring period to ensure no further impact is observed.
Posted 8 months ago. Mar 28, 2018 - 08:59 PDT
Identified
Box is investigating reports of an issue with our Search service impacting a limited number of accounts. Affected users may see a message after attempting a search stating "Sorry, there was an error performing the search. There is a problem with search right now." The list of impacted endpoints is subject to change as the investigation continues.
Posted 8 months ago. Mar 28, 2018 - 08:05 PDT
This incident affected: Box Platform / API (Content API).