Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Box Support Portal unavailable to some users
Incident Report for Box
Resolved
We have not seen any further issues with the Box Support Site.
Posted almost 2 years ago. Jul 06, 2015 - 15:52 PDT
Monitoring
The Box Support Site should be back accessible for all customers. We will continue to monitor.
Posted almost 2 years ago. Jul 06, 2015 - 15:38 PDT
Investigating
https://support.box.com may be unavailable for some users. We are currently investigating.
Posted almost 2 years ago. Jul 06, 2015 - 14:51 PDT