Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[Resolved] Users Unable to Submit Support Cases on the Box Community
Incident Report for Box
Resolved
The monitoring period has ended and we have confirmed full functionality has returned to the web case submission workflow. Thank you for your patience as we worked to resolve this issue.
Posted about 1 year ago. Aug 26, 2016 - 13:02 PDT
Monitoring
The issue impacting the ability to submit cases through the Box Community has been stabilized by our third-party provider. We are continuing to monitor to ensure full resolution.
Posted about 1 year ago. Aug 26, 2016 - 11:15 PDT
Update
The third-party provider has isolated the issue in their system and taken steps to remediate. We are seeing the functionality to submit a support case through the Box Community slowly returning and will continue to monitor.
Posted about 1 year ago. Aug 26, 2016 - 10:42 PDT
Identified
When attempting to submit a support case through the Box Community, some users may receive an error and will unable to proceed further. This is impacted by a third-party provider outage with whom we are actively engaged to resolve.
Posted about 1 year ago. Aug 26, 2016 - 09:00 PDT