Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be experiencing issues accessing Box
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. If you continue to experience any issues, please contact Box User Services at https://support.box.com
Posted 5 months ago. Feb 11, 2018 - 07:00 PST
Monitoring
Box Engineers have remediated the issue. All customers should be able to access Box at this time. Engineering will continue to monitor to ensure no further impact is observed before declaring this as resolved
Posted 5 months ago. Feb 10, 2018 - 18:40 PST
Update
Box Engineers are reporting that systems are coming back online and users should be able to access Box, though we continue to validate the incident has been fully remediated.
Posted 5 months ago. Feb 10, 2018 - 17:48 PST
Update
Box Engineers are close to remediating the issue.
Posted 5 months ago. Feb 10, 2018 - 17:06 PST
Update
Box Engineers are making progress to remediate the issue.
Posted 5 months ago. Feb 10, 2018 - 16:39 PST
Update
Box Engineers are continuing to remediate the issue.
Posted 5 months ago. Feb 10, 2018 - 16:02 PST
Identified
Box Engineers have identified the root cause of this incident and are taking immediate steps to remediate.
Posted 5 months ago. Feb 10, 2018 - 15:37 PST
Investigating
Box Engineering is investigating an issue related to intermittent connectivity issues to Box. Impacted users may find the [Box Web Application] and [API] non-responsive or returning 500 errors.
Posted 5 months ago. Feb 10, 2018 - 14:52 PST
This incident affected: Box Web Application, Content API, Uploads/Downloads, Mobile, and Box Relay.