On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[RESOLVED] Issue with New Case Creation, Viewing and Updating Cases from the Box Community
Incident Report for Box
Resolved
The issue impacting the ability to submit new cases and view and update existing cases on the Box Community has been resolved.
Posted almost 3 years ago. Dec 23, 2015 - 10:39 PST
Identified
We have identified an issue impacting the ability to submit new cases and view and update existing cases on the Box Community site. We are actively working to address this issue. In the interim, please see https://community.box.com/help for other contact options to Box Support. No Box services are impacted by this issue.
Posted almost 3 years ago. Dec 23, 2015 - 07:00 PST