Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

FTP degraded
Incident Report for Box
Resolved
At 6:18 PM PST a fix was deployed to remediate this issue. No further impact has been observed.
Posted about 3 years ago. Nov 20, 2014 - 18:18 PST
Identified
Since 4:30PM PST, some customers may have noticed intermittent connection problems when using FTP.
Posted about 3 years ago. Nov 20, 2014 - 16:30 PST
This incident affected: Box Website.