Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

FTP is unavailable for Box users
Incident Report for Box
Resolved
The issue regarding ftp was previously resolved. We apologize for any inconvenience.
Posted almost 2 years ago. Sep 15, 2015 - 22:53 PDT
Monitoring
We have resolved the issue. Engineers will continue monitoring to ensure stability. Please report any new issues at https://support.box.com.
Posted almost 2 years ago. Sep 15, 2015 - 19:40 PDT
Investigating
We are aware that users are having trouble connecting to Box via FTP. The response received when connecting to our FTP server contains a 421 response code. We are currently working on resolving the issue.
Posted almost 2 years ago. Sep 15, 2015 - 18:32 PDT