For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

Connectivity, Preview and Download Issues in China
Incident Report for Box
Resolved
Our monitoring period for this event has ended and we have seen sustained improvements accessing Box in China. Please contact Box Support (https://support.box.com) if you continue experiencing any related issues.
Posted Jun 26, 2019 - 13:38 PDT
Monitoring
We are seeing improvements accessing Box in China. This includes connectivity to the Box Web Application, Syncing with Box Drive and Box Sync, downloading content with Box Tools, and both Preview and Download functionality on the Box Web Application. While this remains an ISP issue and not something in our control, we are continuing to closely monitor.
Posted Jun 20, 2019 - 14:19 PDT
Investigating
We are investigating reports of issues accessing Box in China. At this time, we believe this to be a localized ISP issue in the region. Problems include slower connectivity to the Box Web Application, Syncing with Box Drive and Box Sync, downloading content with Box Tools, and both Preview and Download functionality on the Box Web Application. We are investigating further, but this appears to be an ISP issue and not something in our control right now.
Posted Jun 11, 2019 - 11:15 PDT
This incident affected: Box Platform / API (Content Preview, Uploads/Downloads), Desktop Applications (Box Sync, Box Drive, Box Edit / Tools), Box Web Application (Uploads/Downloads, Preview), and Mobile Applications (Preview, Uploads/Downloads).