Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may experience increased latencies for uploads and downloads
Incident Report for Box
Resolved
Box engineering has confirmed all issues have been resolved. If you continue to experience any issues, please contact the Box User Services team at https://community.box.com/help.
Posted 6 days ago. Oct 11, 2017 - 12:38 PDT
Monitoring
Box engineering has identified and remediated an issue with our uploads and downloads services. Users may have experienced increased latencies for uploads and downloads. We are currently monitoring all services to ensure no further impact is observed.
Posted 6 days ago. Oct 11, 2017 - 12:18 PDT
This incident affected: Downloads and Uploads.