Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some customers may be unable to view their files on Box.com and a "Please refresh" message is shown
Incident Report for Box
Resolved
We no longer observe the issue anymore. It is now resolved.
Posted almost 2 years ago. Nov 04, 2015 - 22:00 PST
Monitoring
Our engineering team has deployed a fix for the issue. No further occurrences of the issue is detected. We will continue to monitor the situation.
Posted almost 2 years ago. Nov 04, 2015 - 19:12 PST
Identified
We have identified the issue impacting a small set of customers that may experience difficulty accessing or searching for their files. We are working on a fix and will update our status once we resolve the issue.
Posted almost 2 years ago. Nov 04, 2015 - 16:53 PST
Investigating
Some customers may be unable to view their files in Box after logging into our webapp. A message saying "Please refresh" is posted on the page after logging in to Box. We are investigating the cause of this issue currently.
Posted almost 2 years ago. Nov 04, 2015 - 12:50 PST
This incident affected: Box Website and Search.