For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issues with SSO Logins
Incident Report for Box
Postmortem

We recently addressed issues affecting SSO login. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 8:52 PM PT and 9:19 PM PT on September 6th, some users may have experienced difficulties while working in Box. During this time, some users may have been unable to login to Box using SSO. The issue occurred due to resource constraints after migrating SSO service as part of cloud migration efforts. We were able to resolve the issue by to increasing our capacity to handle traffic spikes. In addition, we have improved our metrics for better monitoring of our service to prevent similar issues from occurring in the future. 

Analysis

We migrated the SSO login service to cloud on September 6th at 11 AM PT. This migration was performed during a maintenance window scheduled between September 5th and 8th. As part of this migration, we modified the architecture of the service to match our standard engineering practices. However, during the peak traffic in Japan on the same day, the SSO service was limited by resources and failed to detect the issue. As a result, some users were unable to log in to Box.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Improve monitoring
  • Improve load testing process
  • Performance tuning to enhance resiliency

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Oct 06, 2023 - 14:51 PDT

Resolved
A fix has been implemented and after monitoring the results, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Sep 06, 2023 - 21:24 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 06, 2023 - 21:18 PDT
Investigating
We are investigating an ongoing issue affecting SSO logins. Users may experience login failures. We will provide more information as soon as it is available.
Posted Sep 06, 2023 - 21:05 PDT
This incident affected: Desktop Applications (Login/SSO).