For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issues with Search Functionality
Incident Report for Box
Postmortem

We recently addressed issues affecting Search. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 2:04 PM PDT and 10:32 PM PDT on June 7, 2023, some users may have experienced difficulties while working in Box. During this time, some users may have received partial or no results in response to file searches. The issue occurred due to an underlying infrastructure issue where a Search cluster was missing a portion of its index. We were able to resolve the issue by immediately routing traffic to one of our backup clusters. In addition, we are working to add restrictions and additional checks to better prevent traffic from being routed to an incomplete index in the future. 

Analysis

On June 7th, we performed commands while troubleshooting a separate issue that inadvertently caused a Search cluster to serve customer traffic while missing a portion of its index. This resulted in some customer search queries returning with partial or no results. To remediate this issue, we routed traffic to one of our backup clusters.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Applying checks and restrictions to prevent actions that could result in an empty search index
  • Using automation to perform further checks and restrictions
  • Improving our alerting to catch situations where traffic is routed to an incomplete index

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Jul 07, 2023 - 09:32 PDT

Resolved
After further monitoring, this incident is now considered resolved. All services have been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Jun 08, 2023 - 00:51 PDT
Monitoring
A fix has been implemented and we are continuing to monitoring the results.
Posted Jun 07, 2023 - 23:34 PDT
Identified
We are investigating an ongoing issue affecting Search functionality inclusive of Metadata template search functionality. We have identified the cause and are working on a resolution.
Posted Jun 07, 2023 - 22:47 PDT
This incident affected: Box Web Application (Search).