Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Sync Installer Download Returning 'Access Denied'
Incident Report for Box
Resolved
Access to download the Box Sync installer from sites.box.com/sync4 has been restored.
Posted 7 months ago. Jul 26, 2016 - 08:30 PST
Investigating
Some users are receiving an 'Access Denied' error when attempting to download the latest Sync installer file from https://sites.box.com/sync4. The Box Network Operations Team is investigating.
Posted 7 months ago. Jul 26, 2016 - 07:43 PST