Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some Users May Experience Issues Logging Into Box and Uploading Content
Incident Report for Box
Resolved
Box monitoring metrics indicated login and upload failures. After further inspection, Box engineering can confirm no issues were experienced by Box users. Again, there is no suspected user impact from this event.
Posted 2 months ago. Aug 05, 2017 - 16:12 PDT
Investigating
Box Engineering is investigating an issue that may prevent some users from being able to login to their account and uploading content to Box.
Posted 2 months ago. Aug 05, 2017 - 15:34 PDT
This incident affected: Box Website, Content API, and Uploads.