Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box.com was briefly unavailable.
Incident Report for Box
Resolved
Our Engineering team has resolved the issue.
Posted about 2 years ago. Sep 18, 2015 - 15:42 PDT
Monitoring
Around 10:41am PST, the Box Web App experienced a brief outage that has been recovered. Engineering teams are currently monitoring.
Posted about 2 years ago. Sep 18, 2015 - 10:49 PDT
This incident affected: Box Website.