Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be unable to upload by email
Incident Report for Box
Resolved
The monitoring period has ended and no further impact has been observed. If you continue to experience any issues, please contact the Box User Services team via https://community.box.com
Posted 8 months ago. Dec 21, 2016 - 12:46 PST
Identified
Engineering has isolated the root cause of the issue and queued email uploads are now being delivered.
Posted 8 months ago. Dec 21, 2016 - 11:31 PST
Investigating
Some users may be experiencing issues uploading content to Box via email. No error message is returned and the file is not visible in the intended destination. Engineers are actively investigating.
Posted 8 months ago. Dec 21, 2016 - 09:27 PST
This incident affected: Uploads.