Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Uploads via email and zipped downloads not working
Incident Report for Box
Resolved
Our engineers have resolved this issue, all site components are working as expected.
Posted about 1 year ago. Feb 25, 2016 - 06:52 PST
Update
We are actively processing the files that have been submitted via emails. Some delay is expected while we process the files in the backlog.
Posted about 1 year ago. Feb 24, 2016 - 18:39 PST
Identified
We are aware that zip downloads via our Web App are also affected. Our engineering team is working to resolve the files uploaded via email and the zip files downloaded. Other upload and download channels are working as usual.
Posted about 1 year ago. Feb 24, 2016 - 11:20 PST
Investigating
We are aware that some of the file uploads via email are not completing. We are currently investigating.
Posted about 1 year ago. Feb 24, 2016 - 06:27 PST
This incident affected: Downloads and Uploads.