Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Issues with SSO Login
Incident Report for Box
Resolved
At 2:12 PM PST the fix was deployed to remediate this issue. SSO Login has returned to normal.
Posted almost 3 years ago. Nov 24, 2014 - 14:12 PST
Identified
Our Engineering Teams have identified the root cause of the current SSO login issue. A fix is being prepared. Users can continue to use the workaround of clicking "Not a user of ? Login of Sign Up Here." to login.
Posted almost 3 years ago. Nov 24, 2014 - 11:15 PST
Investigating
Some users who are using SSO may receive an error stating "There was a problem logging into your account. Please contact you administrator for assistance." Our teams are actively investigating. As a workaround, users may click "Not a user of ? Login of Sign Up Here."
Posted almost 3 years ago. Nov 24, 2014 - 09:26 PST
This incident affected: Box Website, Box Sync, and Mobile.